Fix getbalance() bug
[novacoin.git] / contrib / debian / rules
index 6d6f119..3ab9fe9 100755 (executable)
@@ -1,33 +1,25 @@
 #!/usr/bin/make -f
 # -*- mode: makefile; coding: utf-8 -*-
 
-#DEB_MAKE_CHECK_TARGET = test_bitcoin
-#build/bitcoind::
-#      $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
-
-DEB_INSTALL_EXAMPLES_bitcoind += debian/examples/*
-DEB_INSTALL_MANPAGES_bitcoind += debian/manpages/*
+DEB_INSTALL_EXAMPLES_novacoind += debian/examples/*
+DEB_INSTALL_MANPAGES_novacoind += debian/manpages/*
 
 %:
-       dh $@
+       dh --with bash-completion $@
 
 override_dh_auto_build:
-       cd src; $(MAKE) -f makefile.unix bitcoind
+       cd src; $(MAKE) -f makefile.unix novacoind USE_ASM=1 USE_LEVELDB=1
        $(MAKE)
 
 override_dh_auto_clean:
-       if [ -f Makefile ]; then $(MAKE) clean; else rm -rf build/; rm -f bitcoin-qt; fi
+       if [ -f Makefile ]; then $(MAKE) clean; else rm -rf build/; rm -f novacoin-qt; fi
        cd src; $(MAKE) -f makefile.unix clean
 
 override_dh_auto_configure:
-       qmake bitcoin-qt.pro USE_SSL=1 USE_QRCODE=1
-
-override_dh_auto_test:
-       cd src; $(MAKE) -f makefile.unix test_bitcoin
-       src/test_bitcoin
+       qmake novacoin-qt.pro USE_ASM=1 USE_LEVELDB=1
 
 # Ensure wrapper is set executable
-binary-post-install/bitcoind:
-       chmod +x $(cdbs_curdestdir)usr/bin/bitcoind
-binary-post-install/bitcoin-qt:
-       chmod +x $(cdbs_curdestdir)usr/bin/bitcoin-qt
+binary-post-install/novacoind:
+       chmod +x $(cdbs_curdestdir)usr/bin/novacoind
+binary-post-install/novacoin-qt:
+       chmod +x $(cdbs_curdestdir)usr/bin/novacoin-qt