Do not force static runtime for boost unless building for win32
[novacoin.git] / src / CMakeLists.txt
index 7d8f3c5..1940f5f 100644 (file)
@@ -39,7 +39,9 @@ endif()
 set(CMAKE_CXX_EXTENSIONS OFF)
 
 set(Boost_USE_STATIC_LIBS   ON)
+if(WIN32)
 set(Boost_USE_STATIC_RUNTIME ON)
+endif()
 find_package(Boost REQUIRED COMPONENTS atomic chrono filesystem program_options system thread)
 set(OPENSSL_USE_STATIC_LIBS ON)
 find_package(OpenSSL REQUIRED)