libssp is needed only for mingw
[novacoin.git] / src / CMakeLists.txt
index 1940f5f..7c0ea67 100644 (file)
@@ -175,10 +175,9 @@ list(APPEND ALL_DEFINITIONS HAVE_BUILD_INFO USE_IPV6)
 add_executable(novacoind ${ALL_SOURCES})
 
 if (NOT MSVC)
-list(APPEND ALL_LIBRARIES ssp)
 list(APPEND ALL_DEFINITIONS _FORTIFY_SOURCE=2)
 if (WIN32)
-list(APPEND ALL_LIBRARIES mingw32)
+list(APPEND ALL_LIBRARIES mingw32 ssp)
 set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -static-libgcc -static")
 endif()
 endif()