Link with pthread on win32
[novacoin.git] / src / CMakeLists.txt
index 456c35a..b49de36 100644 (file)
@@ -116,7 +116,7 @@ list(APPEND ALL_LIBRARIES ${Boost_LIBRARIES} ixwebsocket OpenSSL::Crypto)
 
 # Windows-specific libraries
 if (WIN32)
-    list(APPEND ALL_LIBRARIES kernel32 user32 gdi32 comdlg32 winspool winmm shell32 comctl32 ole32 oleaut32 uuid rpcrt4 advapi32 ws2_32 mswsock shlwapi)
+    list(APPEND ALL_LIBRARIES kernel32 user32 gdi32 comdlg32 winspool winmm shell32 comctl32 ole32 oleaut32 uuid rpcrt4 advapi32 ws2_32 mswsock shlwapi pthread)
     list(APPEND ALL_DEFINITIONS WIN32)
 endif()