Implement novacoin mining support
[stratum-mining.git] / litecoin_scrypt / setup.py
diff --git a/litecoin_scrypt/setup.py b/litecoin_scrypt/setup.py
new file mode 100644 (file)
index 0000000..8304844
--- /dev/null
@@ -0,0 +1,11 @@
+from distutils.core import setup, Extension
+
+ltc_scrypt_module = Extension('ltc_scrypt',
+                               sources = ['scryptmodule.c',
+                                          'scrypt.c'],
+                               include_dirs=['.'])
+
+setup (name = 'ltc_scrypt',
+       version = '1.0',
+       description = 'Bindings for scrypt proof of work used by Litecoin',
+       ext_modules = [ltc_scrypt_module])