Add debian build folder
[novacoin.git] / contrib / debian / patches / 1001_use_system_json-spirit.patch
1 Description: Use system JSON Spirit library
2 Author: Jonas Smedegaard <dr@jones.dk>
3 Last-Update: 2011-05-17
4 --- a/src/rpc.cpp
5 +++ b/src/rpc.cpp
6 @@ -12,9 +12,7 @@
7  #include <boost/asio/ssl.hpp> 
8  typedef boost::asio::ssl::stream<boost::asio::ip::tcp::socket> SSLStream;
9  #endif
10 -#include "json/json_spirit_reader_template.h"
11 -#include "json/json_spirit_writer_template.h"
12 -#include "json/json_spirit_utils.h"
13 +#include <json_spirit.h>
14  #define printf OutputDebugStringF
15  // MinGW 3.4.5 gets "fatal error: had to relocate PCH" if the json headers are
16  // precompiled in headers.h.  The problem might be when the pch file goes over
17 --- a/src/makefile.unix
18 +++ b/src/makefile.unix
19 @@ -23,6 +23,7 @@
20     -l boost_thread \
21     -l db_cxx \
22     -l ssl \
23 +   -l json_spirit \
24     -l crypto
25  
26  ifdef USE_UPNP