QRCode support is always enabled now;
[novacoin.git] / contrib / debian / rules
1 #!/usr/bin/make -f
2 # -*- mode: makefile; coding: utf-8 -*-
3
4 DEB_INSTALL_EXAMPLES_novacoind += debian/examples/*
5 DEB_INSTALL_MANPAGES_novacoind += debian/manpages/*
6
7 %:
8         dh --with bash-completion $@
9
10 override_dh_auto_build:
11         cd src; $(MAKE) -f makefile.unix novacoind USE_ASM=1 USE_LEVELDB=1
12         $(MAKE)
13
14 override_dh_auto_clean:
15         if [ -f Makefile ]; then $(MAKE) clean; else rm -rf build/; rm -f novacoin-qt; fi
16         cd src; $(MAKE) -f makefile.unix clean
17
18 override_dh_auto_configure:
19         qmake novacoin-qt.pro USE_ASM=1 USE_LEVELDB=1
20
21 # Ensure wrapper is set executable
22 binary-post-install/novacoind:
23         chmod +x $(cdbs_curdestdir)usr/bin/novacoind
24 binary-post-install/novacoin-qt:
25         chmod +x $(cdbs_curdestdir)usr/bin/novacoin-qt