Update to 0.3.0 (New upstream + new RPC calls)
[novacoin.git] / contrib / debian / rules
1 #!/usr/bin/make -f
2 # -*- mode: makefile; coding: utf-8 -*-
3
4 #DEB_MAKE_CHECK_TARGET = test_bitcoin
5 #build/bitcoind::
6 #       $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
7
8 DEB_INSTALL_EXAMPLES_bitcoind += debian/examples/*
9 DEB_INSTALL_MANPAGES_bitcoind += debian/manpages/*
10
11 %:
12         dh $@
13
14 override_dh_auto_build:
15         cd src; $(MAKE) -f makefile.unix bitcoind
16         $(MAKE)
17
18 override_dh_auto_clean:
19         if [ -f Makefile ]; then $(MAKE) clean; else rm -rf build/; rm -f bitcoin-qt; fi
20         cd src; $(MAKE) -f makefile.unix clean
21
22 override_dh_auto_configure:
23         qmake bitcoin-qt.pro USE_QRCODE=1
24
25 override_dh_auto_test:
26         cd src; $(MAKE) -f makefile.unix test_bitcoin
27         src/test_bitcoin
28
29 # Ensure wrapper is set executable
30 binary-post-install/bitcoind:
31         chmod +x $(cdbs_curdestdir)usr/bin/bitcoind
32 binary-post-install/bitcoin-qt:
33         chmod +x $(cdbs_curdestdir)usr/bin/bitcoin-qt